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What’s New 

Cyclone 3DR 2022.1.0 is a major release that includes new features and improvements to the product, for 

both the Desktop and Touch Mode interfaces. In addition to many enhancements, the main new functions 

are: 

▪ More solutions for the AEC Industry 

• BIM Progress Monitoring 

• Export DTM to IFC  

▪ A new Digital Reality Experience including: 

• Scan-to-Mesh 

• New texturing features: Smart Texture, Texture from clouds and diverse tools 

• Export textured and colorized meshes to FBX 

▪ Significant updates for 3D Scene rendering and interactions 

 

According to the maintenance expiration date policy, users under maintenance on 12 June 2022 may 

access version 2022.1 with no new license required. 

BIM Progress Monitoring 

With the 2022.1 release of Cyclone 3DR, AEC users will benefit from the new BIM Progress Monitoring 

workflow. This new BIM-dedicated feature leverages the user interface of Cyclone 3DR inspection tools to 

provide users a smooth workflow to run progress monitoring for any construction site. 

 

This feature is available to users with the AEC and PRO licenses. 

 

Workflow description 

 

The new feature is available in the Analysis menu. To run the new workflow, it’s necessary to select first 

the two aligned inputs: 

▪ The point cloud, representing the measured situation. 

▪ The BIM model, representing the design intention, previously imported in the application. 

 

Optionally, users can benefit from Cyclone 3DR's ability to edit BIM models. This step is not mandatory to 

run the BIM Progress Monitoring but it’s highly recommended to check the contents of the BIM Model 

before running the analysis. As an example, a user may wish to remove the levels of a building that are 

not the focus of the analysis. In addition, removing out-of-scope elements speeds up the analysis process 

because the amount of BIM elements that are analyzed by the inspection algorithm and that are then 

verified by the user is significantly reduced. 

 

 
 

Then the workflow is composed of three steps—analyze, check and export. 
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Analyze 

 

 
 

1. Define the coverage options: 

a. The percentage of covered surface to define if a component is Not Installed / Incomplete / 
Installed. As an example, in many scan jobs in building application, only half the surface 
of the slabs or the walls are captured. In that case, it’s relevant to define 50% to consider 
an object installed. 

b. The tolerance: only the points that are closer to a component than the tolerance (10 cm 
as an example) are considered in the covering-checking analysis. 

 
2. Compute 
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3. Preview of the results: a pie chart displays the distribution of the progress analysis 

Green for Installed 

Orange for Incomplete 

Red for Not Installed 

Grey for No Data (no points at all) 

 
4. Select the “Reset” button to cancel the analysis and change the coverage and tolerance options if 

required. 

5. Select the “Next” button to proceed with a detailed check of the elements. 

 

Check 

 

Before moving forward to the final step, Export, it’s possible to navigate in the second step of the 

workflow, through the different BIM components to check their status and update them if 

necessary.  

 

 
 

1. List of analyzed BIM components: 

The detailed table shows all the components and their results, including the coverage rate, the 

installation status and the median offset from the design position. 

 

It is possible to select a component in the list or in 3D scene to edit its progress status. 

 

The filter buttons allow the user to hide or display components from the list and the 3D scene 

according to their progress status. For example, a user may wish to hide the installed components 

to focus on the incomplete and not installed parts of the design model. 

 
2. The progress view: 

This scene view shows an overview of the analyzed BIM Model, which is colorized according to 

the progress status of each component. 
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3. Tool Tips 

When an object is selected, certain options to manipulate the view and the element are available: 

• Spacebar to edit the installation status 

• H to hide the component 

• Top and Bottom arrows to switch from one object to the previous/next one in the list. 

 
4. 3D Zoom on the selected component 

This 3D scene shows the deviation colormap of the selected object between the point cloud and 

the selected BIM component. It also displays the points considered in the analysis. 

 
5. Select the “Next” button to proceed to the Export step. 

 

Export 

 

 
 

1. Update Report View button: to update the viewset for the PDF report and BCF tickets. 

2. Export to BCF options 

• Export summary only: this option creates a BCF file which is composed of a single issue, that 

contains the view, the distribution results and two attached CSV result files (detailed table per 

component + synthetic table) 

• Export summary and detailed results: this option creates a BCF file which is composed of: 

▪ one issue for summary, that contains the view, the distribution results and two attached 

CSV result files (detailed table per component + synthesis table) 

▪ one issue of each analyzed component. The user may define which statuses get included 

in the results.  
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BIM Progress Monitoring report 

 

Like all the analysis tools of Cyclone 3DR, a report chapter is automatically created in the 3DR project. It 

can be edited through the report editor, then exported to PDF and CSV formats. 

 

 
 

As part of the report, two tables are created: 

• The Type and Status table presents the installation status quantity per object type, which is 

relevant to highlight in an overview report. The table can be exported to PDF or CSV. 
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• The Detailed table that lists the relevant information for all analyzed components: Name / 

GUID Progress status / Coverage / Offsets (min, median, max). 

 

 
 

Exporting the detailed table to CSV can be valuable when the end-user wants to proceed the results in the 

third-party BIM design software application. Thanks to the GUID references, it is possible to add new 

parameters to the objects (and update them later for the coming BIM Progress Monitoring), which provides 

even more flexibility for the users, for example for selection, visualization, colorization needs in the 3rd-

party application. 

 

The CSV detailed table from 3DR BIM Progress Monitoring can be imported in BricsCAD BIM (Hexagon 

BIM software) or can be used in Autodesk Revit (via plugin) for example. 

 

Scan-to-Mesh 

Within the 2022.1 release, the new Scan-to-Mesh feature makes meshing easy and user friendly. Scan-

to-Mesh is based on the core 3DR meshing capabilities, re-tooled to deliver advanced meshes in one-

click. This new feature gives the users the ability to address digital reality applications with even more ease 

where point clouds are not supported. 

 

Scan-to-Mesh workflow: 

 

▪ Select the input point cloud: 

o All formats allowed. 

o The conversion of a JetStream point cloud is not mandatory before running Scan-to-Mesh. 

That means that streamed point clouds from Cyclone ENTERPRISE, JetStream, Cyclone 

REGISTER 360 or LGS files can be directly meshed with the new feature without the 

conversion step. Note that the meshing calculation is faster for a 3DR point cloud object. 

 

Tip: use a Limit Box to reduce the number of points being meshed to save time. All active Limit 

Boxes will be included in the Mesh. Points outside of the Limit Boxes will be excluded. 
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▪ Go to the Surface Modeling menu and run Scan to Mesh: 

  

 
1. Select the Level of detail configuration 

Four modes are exposed in the command: 

• Low LOD: suitable mode for BLK-family Leica scanners 

• Medium LOD: suitable mode for all Leica sensors 

• High LOD: suitable for the most accurate scanners like RTC360 or P-Series  

• User-defined LOD: enabled in the feature to allow users to repeat meshing jobs with pre-

defined custom parameters. 

 

 
2. Evaluate the result locally before running the complete process 

Selecting Evaluation mode allows the user to click in the 3D-scene and position a small limit box, 

in which the data will be meshed to give an estimation of the complete computation time and the 

quality of the result. When in Evaluation mode, it is possible to switch from one LOD to another 

and the region of interest will be meshed again with the new parameters. 

 

Click again on Evolution mode to quit this mode and compute the mesh for the entire scan (with 

Preview or OK). 
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The evaluation mode provides an estimation of the time to compute the whole point cloud. This estimation 

is based on the number of points and selected LOD. 

 

Tip: When Evaluation Mode is toggled on, use the CTRL + Mouse scroll button shortcut to adjust 

the size of the evaluated area. 

 

 
3. Switch from Default to Advanced settings to customize the meshing parameters if necessary. 

In the Advanced settings, the parameters can be visually checked in the predefined 

Low/Medium/High LOD modes. It is possible to change the numerical values in the User-Defined 

mode. 

• Box size: The new Scan to Mesh function uses limit boxes that are iterated to mesh the whole 

dataset step by step, to process a large amount of points. It is possible to review the size of 

the cube box through this parameter. 

• Average distance (between the points of the cloud) 

• Minimum triangle size: to control the size of the mesh surfaces 

• Ignore scanning directions: the output mesh would be properly orientated with this check box 

option and is relevant when the point cloud contains scan directions (static TLS sensors). 

• Create textured mesh: check box option to add texture to the output mesh (the texture comes 

from the point cloud RGB colors in Scan to Mesh) 
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4. Click OK or Preview to compute 

Click and enjoy the mesh result, ready to be consumed in Cyclone 3DR or in a third-party 
application. 

 
Medium-LOD Mesh from a BLKARC scanner 

 

Note that Scan-to-Mesh feature has been designed mainly for Leica Geosystems scanners but can be 

used on a point cloud of any format. 

 

The main application for the feature remains the indoor application and gives realistic models for the 

Building or the Plant industries. 

 

This feature is available to users with the STANDARD license. 
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New Texturing features 

The Cyclone 3DR 2022.1 release includes many new features and improvements for Texturing, including: 

• Smart Texture 

• Texture from clouds 

• Diverse tools to improve texturing jobs: 

▪ Spherical from Perspectives 

▪ Clear Mask,  

▪ The renewed Estimate Pose feature. 

• A new favorite script: Colorize cloud from image 

 

Smart Texture 

Smart Texture is a new engine to texture meshes from camera images. 

 

Smart Texture is easy to run. Like the existing Standard Texture feature, select the input mesh and the 

camera images, and run Smart Texture in the Texturing menu.  

 

Note that all the selected camera images must be of the same type—spherical only or perspective only. 

The new feature Spherical from Perspectives can be used before to standardize the input images. 

 

The following options are available within the Smart Texture menu: 

 

 

 

 
1. Users can select additional meshes 

which contain obstacles to exclude from 
the texturing job to improve the overall 
results. This option is useful when there 
are objects like trees, cars, pedestrians 
in the scan. It is recommended to create 
a compound mesh of the different 
obstacles before running the command. 
Click on the arrow to enable the selection 
mode of the obstacle mesh. 

2. Define the size of one pixel 

3. Existing texture options 

4. Click OK or Preview to compute 

 

Whereas the existing Standard Texture feature returns a dynamic texture for the meshes, the new Smart 

Texture feature delivers mesh with a static texture but with a higher level of quality. The main differences 

from the new Smart Texture are: 

• A higher texturing “score”, which means that the new algorithm is leveraged and picks a better 

image to texture a vertex. 

• A smoother blending capacity between textures coming from 2 different images. 
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• And a cleaner result with the removal of the “black holes” that are common for TLS scanner 

image. A new mask feature enables this capacity. Refer to the new isolated feature Clear 

Mask in Texturing menu. 

• A lighter result: due to the static aspect of the texture after the computation (local editing of 

texture is not permitted except removal of textures), Smart Texture gives the capacity to 

address a much larger number of images. 

 

 
Plant site before applying Smart Texture 

 

 
Same Plant site textured with Smart Texture 
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Same Plant site textured with Standard Texture 

 

 

The Standard Texture feature remains a valuable tool because it returns a dynamic result that can be 

edited with more flexibility. 

 

This feature is available to users with the SURVEY and PRO licenses. 
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Texture from clouds 

Part of the Texturing menu, this new feature replaces the previous one “Take color from cloud”. This 

command will texture a mesh model with the RGB colors from point clouds. Thanks to a new texturing 

engine, the tool automatically creates a textured mesh from the inputs. 

 

This workflow is useful when the scan job does not have georeferenced images to texture the future mesh. 

To start, select the point clouds (multiple input point clouds can work) and the mesh (ideally meshed from 

the point cloud) and run Texture from clouds in the Texturing menu. 

 

 

 
1. Main options 

a. Distance between the mesh and 
the point cloud to apply the 
texture from the RGB value. 

b. Size of the texture pixel on the 
mesh: a single RGB can be 
applied for each pixel. 

 
2. Checkbox to texture the mesh from the 

inspection colors of the point cloud 
inputs instead of the RGB real color 
information. This option is relevant for 
use cases that require to share 
inspection information with other 
stakeholders through a model. As an 
example, a mesh textured from a 
heatmap can be exported to OBJ and 
visualized in TruView or Cyclone 
ENTERPRISE. 

 
3. Option on existing texture 

a. Preserve existing texturing will 
only add a new texture where 
none exists already. 

b. Update current texturing will 
overwrite all existing textures in 
the project. 

 

4. OK or Preview to compute the texture. 
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Example of facade textured from the point cloud RGB colors 

 

Note that the new Scan-to-Mesh feature will automatically apply the Texture from clouds feature when the 

input point clouds have colors. 

 

This feature is available to users with the STANDARD license. 
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Spherical from Perspectives 

This feature converts a group of perspective images to one or multiple spherical images, can yield better 

texturing results. 

 

To convert perspective images to spherical: 

• Select the group of perspective images and run Spherical from Perspective 

 

 
 

Example of 6 cubic-face images before grouping 
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1. Define the clustering method depending 

on the positions of the input images: 

a. Strict: to cluster the images that 
have strict common position. 
Appropriate for a group of 6 
cubic faces from a scan setup 
position. 

b. Group image positions: define a 
distance to group close images. 
Appropriate for multiple images 
captured from another device 
than an accurate scanner. 

 
2. Click Preview to compute the grouping. 

 
3. Visualize the results in the dialog before 

accepting the result.

 

 

When grouped, the images can then be used to texture a mesh for example. 
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Result from the grouping operation from the 6 cubic-face images to a single spherical image 

 

 

 
Preview of the compiled spherical image 

 

This feature is available to users with the SURVEY and PRO licenses. 
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Clear Mask 

Imported spherical and pinhole images now store a textured mask which allows users to skip the picture 

area during texturing process. Currently only the black and white colors are taken into account. The 

purpose of this new tool is simply to give users the ability to clear this mask before running Smart Texture 

if the user decides not to apply the mask on the pure black or pure white area. 

 

The workflow is straight forward: 

• Select the images to clear 

• Run the Texturing > Clear Mask Feature 

• A notification will confirm the clearing operation. 

• Then a Smart Texture operation from this image can be reprocessed and the mask won’t be 

applied. 

 
 

This feature is available to users with the SURVEY and PRO licenses. 
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Estimate Pose 

The existing Estimate Pose feature part of the Texturing menu is improved with the 2022.1 release of 

Cyclone 3DR. This command has been optimized to bring more flexibility to users when they prepare their 

camera images before the texture job in Cyclone 3DR. 

 

In addition to the existing features of the command Estimate Pose, the new capacity is the management 

of the selected points used as reference to pose the camera, with the functionality to disable/enable a point 

in the process of the pose. 

 

 

1. Type of input image 

 
2. New Point pairing feature, including an 

on/off toggle to apply the selected point 
in the posing process 

 
3. Import / Export txt file that contains a list 

of point pairs 

 

4. Visibility option of the estimated image: 
useful to check the result 

 

5. Detailed information on the results of the 
posing operation 
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To execute the operation, it is necessary to select the image to pose and keep it unhidden in the  3D Scene 

that will be used for the workflow (ideally a mesh or a point cloud).  

 

 
 

After validating the new position, it is then possible to properly texture a mesh model from the image or 

colorize a point cloud. 

 

This feature is available to users with the SURVEY and PRO licenses. 

 

Favorite script: Colorize cloud from image 

The new pre-defined script, Colorize cloud from image, adds RGB colors to a point cloud which does 

not have any colors. This is particularly useful for point clouds coming from UAV sensors which are often 

lacking color information. 

 

To run the script, a point cloud and georeferenced camera image must be selected first. 

 

 
 

Note that the function only works with a single image. To colorize a point cloud with multiple images, the 

user must proceed step by step or create another script that will iterate the new function. 
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Example of non-colorized point cloud for heritage indoor application 

 

 
Same point cloud after colorization 

 

This script function is available to users with the STANDARD license. 
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New file formats to export mesh models 

Export Textured Mesh to FBX 

In addition to the common OBJ or GLB formats, FBX file format can now be used to export textured and/or 

colorized models. 

 

To export a mesh to FBX, select the mesh model to export, go to the File menu and click export. 

 

Note that FBX file format is appropriate to export a model with texture or color information. Exporting the 

texture or color information is optional and can be adjusted by the user before validating the creation of 

the FBX file. 

 

For a textured mesh, the following checkbox is exposed: 

 

 
 

 
Example of a textured mesh model from Cyclone 3DR to Autodesk Viewer 

Antic Heritage Site 

 

For a colorized mesh, the following choice is suggested to the user: 
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Example of an inspected BIM Model from Cyclone 3DR to Blender 

Building Construction Site 

 

The main applications for the FBX formats are visualization or monitoring in 3rd party applications or viewer 

solutions for: 

 

• The Construction industry (Autodesk Navisworks) 

• The Media & Entertainment industry (Blender, Autodesk 3DSMax) 
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Textured mesh of a PLANT site created in Cyclone 3DR 

 

 
Textured mesh exported in FBX format from Cyclone 3DR than imported in Autodesk 3DS Max 

 

This feature is available to users with the STANDARD license. 

 

Export DTM to IFC 

 

DTM Mesh Models can now be exported in IFC format to support AEC applications. Thanks to this feature, 

Digital Terrain Model can be exported in one-click to any BIM software applications. 
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Begin by creating a DTM model in Cyclone 3DR. Then, select the DTM mesh model, go to the File menu 

and click Export. 

 

The following options are proposed in the export dialog: 

 

 
 

 
 

DTM from a heavy construction worksite captured with BLK2FLY 

 

Then the DTM can be imported and visualized in all the BIM software solutions like BricsCAD products 

(Hexagon), Revit or Navisworks (Autodesk), Covadis (Geomedia), IFC viewers (Solibri, BIMVision, Dalux, 

…) and many other BIM applications. 

 

The DTM mesh model is automatically classified in the IFCSite family with the IFC export in the 2022.1 

release of Cyclone 3DR. 

 

The main applications to export DTM to IFC are: 

• Architecture: representation of the Terrain Model in BIM design software 

• Engineering: calculation of volumes and terrains 

• Construction: preparation of a construction site 
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Same DTM exported to IFC and reimported into Autodesk REVIT 

 

Part of the applications, a design model can be visualized in its real environment represented by the DTM. 

Below, here is a building model in Autodesk Revit with the DTM exported from Cyclone 3DR: 

 

 
 

Note that any kind of mesh model in Cyclone 3DR can be exported to IFC with the new feature. That 

means that any refined models of an existing construction like a facade or a statue can be also exported 

to IFC, which can be helpful for Heritage applications. Consider with the 2022.1 release, that the IFC export 

classifies the exported objects to the IFCSite family only. 

 

This feature is available to users with the AEC or PRO licenses. 
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3D Scene rendering and interaction 

Surface Model rendering: 

The rendering engine for Surface Model (meshes, CAD models and geometric features) has been 

enhanced in Cyclone 3DR to support two new visualization options: 

 
▪ Doll House view 

▪ New transparency capacities that significantly smooths the rendering of the edges and the 
lines for a better visual experience 

 

This feature is available to users with the STANDARD license. 

Dollhouse view 

The Dollhouse feature is easy to use and can be enabled via the CTRL+D shortcut or from the specific 

toggle button in the View menu. 

 

 
 

The purpose of the Dollhouse rendering mode is to provide a realistic view of inside a mesh model. The 

use of this feature is dedicated to visualization of Indoor applications like Building Construction, Real 

Estate, Operations and Facilities, etc. because it’s necessary to benefit from a model meshed from a point 

cloud with proper scan directions. 

 

The example below shows a relevant mesh model that has a structured orientation: 

 

 
Mesh representing a model of an office floor 
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▪ The inside faces of the model are colorized in Gold 

▪ The outside faces of the model colorized in Blue. Those faces will be hidden from the user’s 
point of view when the Dollhouse rendering is active. In other words, the ceilings and the walls 
on the foreground are hidden by the Dollhouse toggle, which is ideal for textured mesh 
visualisation and video creation. 

 

 
Same textured mesh model with deactivated Dollhouse rendering 

 

 
Same textured mesh model with activated Dollhouse rendering 

 

 

This feature is available to users with the STANDARD license. 
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Transparency rendering 

The new rendering engine of Cyclone 3DR 2022.1 has significantly improved the quality of the transparent 

surface models in the 3D scene. The main advantages for users are: 

 
▪ A much nicer visualization to create views or animations 

▪ A better experience for any kind of workflow that requires lots of scene interactions with surface 
models 

▪ A better management of the depth view, which means that overlaying surface areas have now 
a better representation to understand the scene in 3D. 

 

To illustrate the value of the new realistic rendering, the two examples below can show the difference 

between the old and the new rendering engine. 

 

   
Transparent mesh of an Old Town Street 

With the 2022.0 rendering engine /// With the 2022.1 version 

 

  
Transparent mesh of PLANT site 

With the 2022.0 rendering engine /// With the 2022.1 version 

 

This feature is available to users with the STANDARD license. 
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Smart point picking features for JetStream point clouds 

The following Smart point picking features have been implemented for JetStream point clouds (LGS files 

or connected projects in Cyclone ENTERPRISE, Cyclone REGISTER 360 or Cyclone CORE): 

 
▪ Highest Point 

▪ Lowest Point 

▪ Ground Point 

 
 

With the 2022.1, the conversion of a JetStream point cloud to a 3DR point cloud object is not mandatory 

anymore, which provides lots of time savings to extract information from a streamed point cloud. 

 

This time-saving capacity is very useful in situations where the selection of specific points is necessary to 

extract features like polylines or geometries. The extraction of break lines benefits significantly from this 

improvement. 

 

 
Break line extraction from a native LGS tunnel sample 

 

This feature is available to users with the SURVEY and PRO licenses for GROUND POINT. 

 

This feature is available to users with the AEC, SURVEY and PRO licenses for HIGHEST POINT and 

LOWEST POINT. 
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Support of 3D Mouse 

3D Mouse is supported within Cyclone 3DR and can offer a better experience to 3D Mouse owners. 

 

Users should verify the 3D Mouse Cyclone 3DR general settings and adjust the parameters according to 

their: 

 

 
 

This feature is available to users with the STANDARD license. 

New camera features 

The 2022.1 release of Cyclone 3DR provides a series of new camera features that leverage the user 

interface and offers flexibility and time saving to users. 

 
▪ Camera Toolbar: A short access to the six predefined orthogonal views is available in the 

toolbar and is consistent with other Cyclone software products. 

 
 

▪ Side ortho: The new mode “Side ortho” allows to rotate the camera view around the vertical 
axis. It is automatically active when one the pre-defined views is selected: Front, Back, Left or 
Right. 

Maintaining the left button of the mouse allows the side rotation around the Z axis and keeps 
the side view. 
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▪ 2D vertical rotation (Cyclone profile): When the camera is positioned in Top or Bottom Ortho 
mode, the rotation around the vertical axis is automatically active. 

Maintaining the left button of the mouse allows the side rotation around the Z axis and keeps 
the horizontal view. 

 
 

This feature is available to users with the STANDARD license. 
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View > Capture View 

The new Capture View command allows the user to create high resolution image captures of the scene. 

The exported image from Cyclone 3DR can be used for any kind of generic illustration with a high-

resolution quality. 

 

The workflow to create the view is composed of the steps: 

 
▪ Adjust the scene position and orientation to capture 

▪ Run Capture View from the View menu 

▪ Adjust the view according to the following options: 

1. Image resolution 

2. Background color 

3. And save the image to JPG, BMP, TIF or PNG image format. 

 

 
 

View of new Capture View command 
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High Resolution image with white background from Capture View 

 

 

The new Capture View functionality can be distinguished from other features like: 

 
▪ Save Viewset (from the View menu): a viewset remains dynamic and it is possible to show 

later in the workflow the saved viewset, to update it if necessary, and finally to automatically 
integrate it in report chapters. In contrast, a captured view is static and exported to a standard 
image format to consume in 3rd party applications. 

▪ Extract Ortho-image (from Texturing menu): this feature is really dedicated to creating 2D-
view for consumption in 3rd-party CAD application, whereas Capture View provides 
illustrations. 

 

The Capture View feature is also available in script via the CreatePicture function. 

 

This feature is available to users with the STANDARD license. 

 

View > Lock view 

The “Lock view” capacity has been added in the 2022.1 release of Cyclone 3DR, for “Limit slice along a 

curve”. 

 

As soon as the 3DR project contains a limit slice created along an axis (any polyline object), the user can 

lock the scene view direction to the local direction of the curve. This feature is available in the View menu 

and can be activated or deactivated. When activated, it always locks the view along the curve when the 

slice is scrolled along the axis with the CTRL + MOUSE SCROLLING button. 
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This feature offers a very nice interface for users who need to properly visualize data along a curve, in 

particular to conduct cleaning of linear infrastructure like tunnels or roads. 

 

 
View of slice with deactivated Lock View feature: the user can rotate the scene 

 

 

 

 
Same of slice with activated Lock View feature: the user cannot rotate the scene and can scroll to move 

forward or backward along the curve and keep the slice 
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The feature gives lots of flexibility in many commands like Clean-Separate Point Clouds. 

 

Tip: Use the CTRL + Space shortcut to display the active limit slice, the use the CTRL + Mouse 

scroll button to move along the curve (according to the defined step of the limit slice along a 

curve). CTRL + Space quits the limit slide edition command. 

 

This feature is available to users with the STANDARD license. 
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Surface Modeling > Clean-Separate by triangle size 

Users can now clean a mesh based on the triangle size. This option may be useful in datasets which 

contain noise at the perimeter as is the case with some DTM mesh models that may create unexpected 

border triangles. 

 

 
 

The Surface Modeling command tool provides a new function “By size”, that displays a slider that is easy 

to shift to low dimension or to high dimension. The purpose is to select only the triangles that are smaller 

or bigger than the user value. 

 

 
 

In one-click, the user can then delete, keep only or split the selection. 
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DTM mesh model from a very noisy point cloud 

 

 
DTM mesh model cleaned from the border irrelevant triangles (larger dimensions) 

 

 

This feature is available to users with the STANDARD license. 
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New SBim Script class 

With the 2022.1 release of Cyclone 3DR, a new SBim class is created to offer users more flexibility in 

creating automated and repetitive tasks for their jobs in the construction industry, that involve BIM Models 

(IFC and REVIT file format). 

 

Part of the main functions that are released for BIM workflows in script are: 

 
▪ FromFile(): The purpose is to identify an IFC or RVT file on the computer and to import it in a 

Cyclone 3DR project. This function provides an option to filter certain types of components like 
walls, slabs, Level1, … 

▪ ApplyFilter(): Once a BIM model is imported in Cyclone 3DR, this script function enables the 
capacity to filter certain types of components. The function is similar to the FromFile filter option 
to give more flexibility. Multiple filtering operations could be used in an automated process. 

▪ ConvertPoly(): After the import operation, this function converts the BIM object to a mesh. 

▪ GetMetadata(): This function takes the converted mesh as input and returns the list of the 
medadata contained in the original BIM Model. 

The script documentation completes in detail the description of the SBim class and of the core functions. 

Script document is directly accessible from the Help menu or from the Script module. 

 

This feature is available to users with the AEC and PRO licenses. 

 

Cyclone 3DR Viewer > Migration to CLM 

 

With the 2022.1 release of Cyclone 3DR, the free Viewer application will now be licensed through CLM as 

is the standard Cyclone 3DR application. Users should fill out the form on the official website. An EID will 

be automatically delivered to the requestor via email along with the installer. 

 

The installation of CLM is automatically launched with the installer of Cyclone 3DR Viewer. 

 

  

https://leica-geosystems.com/products/laser-scanners/software/leica-cyclone/leica-cyclone-3dr
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Improvements 

 
▪ Analysis > Clash: One limit box is enabled for each clash cluster. 

 
▪ Analysis > Localize values: Added unit support and provided a way to fill the list of thresholds 

by clicking directly on the inspected object. 

 

 
 

▪ Analysis > Inspection notes / BCF: Removed the ability to select objects other than the input 
inspected BIM Model when creating notes in the 3D Scene to prevent users from accidentally 
selecting them and existing the tool. This improvement improves the user interface by giving 
the users the opportunity to display other objects, like the point cloud whose visualization 
brings real context information for the screenshots attached to the notes. 

 
▪ Camera (3DReshaper profile): Standardized options with Cyclone 3DR profile: 

a. The reference plane now matches the Z axis of the current UCS 

b. Add Fly mode 

c. Cross wall option is only available through the CTRL + mouse wheel action. 

 
▪ Clean > Walls and Floors: 

a. Additional option to adjust the surface used to compute the local normal. 

b. Floors and Ceilings are segmented when scan directions are available. 
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▪ Coord Sys > UCS: Improved normal direction extraction on mesh and BIM objects for 
Wall/Wall + Wall/Floor + Wall. 

 
▪ Extract > Contour lines: New shortcut to export contour lines as DXF or via Send To in the 

command dialog. 
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▪ Extract > Points on Grid: New option to control the extraction radius around each grid point. 

 
 

▪ Extract > Projection: When projecting a point cloud, points not projected are no longer added 
to the output point cloud. 

 

▪ File > Edit BIM Model: Added a way to update the path of the file if it is missing. 
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▪ File > Export GLB: Added an option to export inspection colors, in addition to textures 

 
 

▪ File > Export LAS/LAZ: Added an option allowing export of the colors of the classes instead 
of the real colors (RGB information of classified point clouds). 

 

 

▪ File > Import BLK360G1: A spherical image is now produced instead of several pinhole 
images. 

 

▪ File > Import LandXML: 

a. Added support for HeXML 2.0 extension. 

b. Added support for InfraModel files (version 4.0.4). 

 

▪ File > Send to SketchFab: 

a. Meshes are now exported as GLB file. 

b. Added the support of classified point clouds. 

 

▪ License: Support of CLM 2.6.2 

 

▪ Report > Management of user variables and new settings: 

a. Report data template: User data can be pinned to Cyclone 3DR Application and 
behave like settings or unpinned to Cyclone 3DR project and be applied to the current 
report only. This new mechanism is a significant improvement to offer much more 
flexibility and time saving to users working on multiple 3DR projects that need rework. 

 
b. Custom data (text variables and images) and decimal settings are preserved between 

sessions. 
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c. Report chapters with missing or no data (after editing an analysis) are automatically 
removed. 

 
▪ Script: Added a new namespace STexturingUtil which gathers all texturing related usages. 

Refer to the Deprecated List section to get the list of all deprecated texturing functions. 

 

▪ Touch Mode BIM Inspection > Colormap: Added the ability to load a user-favorite gradient 
(RSI file). 
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▪ User Interface > Command: Added a new shortcut for “OK, Next” action for all the concerned 

commands with CTRL+ENTER. For example, the geometric feature extraction commands 
(manual drawing or region grow) provide the “OK, NEXT” ability to extract multiple objects. 

 

 
 

CTRL+ENTER is the keyboard shortcut to do OK, NEXT. 
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Bug Fixes 

 

In 2022.1.0 release: 

 

▪ Analysis > Compare Inspect Mesh vs Cloud: Fixed non-deterministic values on the output 

result. 

 

▪ Analysis > Compare Inspect Cloud vs Sphere: Some areas of the inspected point cloud were 

not colorized. Fixed those missing parts. 

 

▪ Analysis > Unroll along axis: Repaired the possibility to change the axis in the command. 

 

▪ Extract > Grid Projection: Repaired the default coordinate system selection. Now the active UCS 

is considered by default. 

 

▪ File > Import DXF/DWG: Fixed import of polyline with elevation. 

 

▪ File > Import DXF/DWG: Fixed imported text position in some cases. 

 

▪ File > Import IFC: Fixed missing faces when importing element in big coordinates. 

 

▪ File > Import IFC: Improved reading of transparency value. 

 

▪ File > Import FLS: Fixed issues when importing FLS files in Windows 11. 
 

▪ Report: Repaired the possibility to save a project that contains a large amount of report data. 

 

▪ Reverse Engineering > Hole: Preserved orientation of the input patch after the computation. 

 

▪ Script: Repaired DWG import through SSurveyingformat.ImportProject function. 

 

▪ Tank > Create color map: Inspected mesh is now created in the right position. 

 

Generic specifications 

Leica Cyclone 3DR 2022.1 Compatibility 

Cyclone 3DR is compatible with CLM 2.5.0.0 and higher.  

Cyclone 3DR is compatible with JetStream ENTERPRISE 1.3 and higher.  

Cyclone 3DR is compatible with LGS files. 

Cyclone 3DR is compatible with Cyclone ENTERPRISE 2022.0 and higher. 

Cyclone 3DR is compatible with Cyclone REGISTER 360 2021.1 and higher. 

Cyclone 3DR is compatible with Cyclone IMP databases from Cyclone 6.0 or higher, however 

improved rendering will only be seen with IMPs from Cyclone 9.3 or higher. 
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Recommended Computer Specifications 

 

Regular workflows in desktop application: 

CPU: 2 GHz Dual Quad Core i7 or higher (i5 minimum) 

RAM: minimum 16 GB or more for 64-bit OS 

Graphic Card: NVidia Quadro or GeForce 1 GB (with OpenGL support, versions 4.3 or higher) 

Operating system: Microsoft Windows 7, 8, 10 (64 bits supported) 

Hard Disk: 3 GB free disk space 

 

 

Tablet device for Touch Mode: 

Microsoft Surface PRO Core i7 1.5 GHz – 16GB RAM. 

 

 

Minimum specifications for Auto-classification (in addition to other recommended specifications 

for the desktop application: 

RAM: minimum 32 GB  

Graphic Card: NVidia with GPU capabilities 

Hard Disk:10 GB free disk space 

CUDA® 11.2 Toolkit (from NVidia). The 11.2 version of CUDA is mandatory for Auto-

Classification. 

 

Installation and Licensing Recommendations 

Installation update Procedure  

 

1. Follow the directions in the Setup Wizard  

 

  
 



 

50 
 

2. Select the option to update Cyclone 3DR (or repair if you want to change installing options) 

  
 

3. Complete the installation by selecting “Finish”. 

 

Licensing Setup  

1. Once you have installed Cyclone 3DR, open the Client License Manager for Floating Licenses. 

The program is located here: Start Menu | All Programs | Leica Geosystems | Client License 

Manager 

 

 

*NOTE* Be sure to choose the CLM Floating option (there are two CLM options 

and the Nodelocked CLM will not activate your license)  

2. Choose the "Activate new licenses" option.  
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3. Enter your Entitlement ID (EID) in the field. To enter multiple EIDs separate them with a semicolon 

";" and no space. 

 

 
 

4. After you have entered your EID, choose the "Check for Activatable licenses" button in the bottom 

right of the page 

 

 
 

5. Once your licenses are activated you can launch Cyclone 3DR.  

6. Go to Settings and select License. 



 

52 
 

 
 

7. If you have entered the EID inside your local CLM, select Localhost. If the license is on a 
dedicated server, enter the server name in Server Address. 
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8. You can select the features you want to check out from CLM. The available options to checkout 
will correspond to the options you purchased which are contained in your EID. 

 

 
 

9. Once the options are selected, click on Activate license. 
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Licensing 

All users with valid CCP or CCP which was valid as of 12 June 2022 for Cyclone 3DR, can run this new 

version of Cyclone 3DR. 

 

All users with valid CCP or CCP which was valid as of 12 June 2022 for 3DReshaper, can run this new 

version of Cyclone 3DR with no new license required. 

 

Users with 3DReshaper licenses with expired CCP must migrate to Cyclone 3DR in order to continue to 

access updates and support. Please contact your sales or support personnel for more information.  

 

 

Known Issues 

 

▪ The Documentation Center is only available in English. 

▪ Some CAD import and export issues might happen. For example, when exporting a cloud in DXF, 

some entities might be missing. To avoid this, it is preferable to use the Send to AutoCAD option. 

▪ If DXF can be imported with a standard version, DWG requires the AEC or PRO Edition. One 

workaround is to use the 3DSend command from AutoCAD to Cyclone 3DR. 

▪ .RSH files are natively compatible with Cyclone 3DR, and the last version of 3DReshaper is 

compatible with .3DR files (with a limit on textures and CAD objects). 

 
  



 

55 
 

Leica Cyclone 3DR supported file formats 

Please reference the Cyclone 3DR Technical Specification for a complete list of supported file types per 

license.  

 

 Import Export 

Point 

Cloud 

Files ASCII (*.asc, *.csv, *.xyz, *.yxz…) 

Leica Geosystems (*.pts, *.ptx) and LGS 

(*.lgs) 

Leica Nova MS50/60 (*.sdb, *.xml) 

ShapeGrabber (*.3pi) 

3DReshaper binary file (*.nsd) 

AutoDesk DXF (*.dxf) 

STL (*.stl) 

Polyworks (*.psl) 

Leica T-Scan + Steinbichler (*.ac) 

LIDAR data (*.las; laz) 

Other ASCII (*.*) 

Zoller and Fröhlich *(.zfs - *.zfc) 

PLY points without triangles (*.ply) 

ESRI ASCII (raster format *.asc) 

FARO (*.fls - *.fws) 

POLYWORKS (*.psl) 

E57 (*.E57 files) 

LandXML files (*.xml) 

DOT Products (*.dpl) 

RDBX 

ASCII FILES (*.asc, *.csv…) 

Binary files (*.nsd) 

Leica Geosystems (*.pts, *.ptx, *lgs) 

E57 (*.e57) 

IGES (*.igs) 

LAS (*.las) 

LAZ (*.laz) 

Autodesk DXF (*.dxf) 

 

Mesh STL format (*.stl) 

Binary PBI format (*.pbi) 

DXF 3Dface format (*.dxf) 

Ascii POLY format (*.poly) 

OBJ format (*.obj) 

Ascii Leica format (*.msh) 

OFF files (*.off) 

PLY (*.ply) 

GLB format (*.glb, *gltf) 

 

Ascii and binary STL format (*.stl) 

Binary PBI format (*.pbi) 

DXF 3Dface format (*.dxf) 

Ascii POLY format (*.poly) 

Vertices only (*.asc) 

DXF polyline (*.dxf)Ascii Leica format 

(*.msh)PLY (*.ply) 

LandXML (*.xml) 

OBJ format (*.obj) 

GLB format (*.glb) 

FBX format (*.fbx) 

IFC / IFCSite type (*.ifc, *.ifczip) 
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Contour / 

Section 

IGES format 

DXF polyline format 

Binary MLI format (*.mli) 

 

IGES format 

DXF polyline format 

Binary MLI format (*.mli) 

ASCII formats 

CAD / BIM 

Models 

IGES 

STEP 

DWG 

IFC 

RVT 

IGES 

STEP 

DXF 

Project Cyclone 3DR (*.3dr) 

DXF - DWG 

XML 

Cyclone ModelSpace View (from IMP) 

JetStream Enterprise project  

Cyclone 3DR (*.3dr) 

DXF 

PDF 3D 

SKETCHFAB 

Report  PDF 

CSV 

BCF 

Image BMP 

JPEG 

JPG 

PNG 

Ortho-image including georeferencing 

information as TXT file 

JPG 

JPEG 

BMP 

PNG 

TIF 

GIF 

 

Cyclone 3DR provides “SendTo” features as well to import and export certain kinds of data with third-party 

products. More information is available in Cyclone 3DR documentation center (from the software help 

menu). 

 

 Send From Send To 

Point Cloud - - 

Mesh / 

Surfaces 

AUTODESK AutoCAD 

HEXAGON MineSight 3D 

AUTODESK AutoCAD 

HEXAGON MineSight 3D 

Contour / 

Section / 

Points 

AUTODESK AutoCAD 

HEXAGON MineSight 3D 

AUTODESK AutoCAD 

HEXAGON MineSight 3D 

CAD Model AUTODESK AutoCAD - 

Image - AUTODESK AutoCAD (ortho-image) 

 


